Bec (preciouslilme) wrote in menstrual_cups,
Bec
preciouslilme
menstrual_cups

My last period was my first time using my Diva but I only used it for the first two days because even though I usually have a heavy flow then the cup held hardly anything. I thought maybe this was just because pads/tampons create the illusion of more blood but I stopped using it for that cycle anyway just in case because I needed my period finished by a certain day. By the end of it my period lasted for two days longer.

Yesterday my period started and I decided to use the cup again. I stcuk it in for an hour but it started to leak so I took it out, rinsed it and stuck it in again, this time keeping it in for 8 hours. When I took it out a second time it had the same amount of blood in it that it had the first time after just an hour!

Is it likely that I'm doing something wrong when inserting the cup or that the super suction of the Diva is actually slowing my flow down? I'm usually quite heavy for my first few days but so far when I've used the Diva I end up with hardly anything in the cup 9even when it's not leaking), as if it takes a lot longer for the blood to leave my body. I'm really at a loss as to why this is and whether I can fix it!
Tags: divacup, teething troubles
Subscribe
  • Post a new comment

    Error

    Comments allowed for members only

    Anonymous comments are disabled in this journal

    default userpic

    Your reply will be screened

    Your IP address will be recorded 

  • 12 comments