?

Log in

No account? Create an account
31 March 2016 @ 10:16 am
Hello,

For context, I am 32, and have had a c-section but no vaginal births. I've been lurking here for a while, and have tried to trouble shoot on my own.

I've been using a Lunette Size 1 cup for a few month now pretty successfully (after removing the very pokey stem on day 2 - ouch!). There have been some issues with getting it to open properly. It just feels too soft inside, and even by pushing on the back of my wall and using the 7 and origami folds; it never felt truly open and round, but seemed to work.

However, I went off of birth control this month to prep for pregnancy soon, so my cycle is much heavier this month. I'm thinking that maybe the popping problems I was having never really resolved and now that the flow is heavier it is no longer working. I'm getting major gushes, but the cup is still partially full when I pull it out to reinsert.

Complicating this problem is that I must have a very high cervix - the cup naturally goes very far up, to the point that I have to really bear down to get ahold of it for removal, and sometimes it takes a while to grab enough of the bottom to get it. This also makes it difficult to check for a good seal because it's really hard to reach in there and I feel like I'm going to dislocate a finger or wrist trying to reach so far.

Is it the cup size? Technique? Any ideas?

Thanks!
 
mommac2b on March 31st, 2016 02:50 pm (UTC)
Thank you - I didn't remove the whole stem, maybe about 1/2-2/3. When I say pokey, I mean it was so irritating that caused my canal to burn when I peed. It HURT and was rubbing me raw.

So the stem had to go. I don't think I want to go softer, either, due to problems with getting the Lunette open.

Thanks for your suggestions. I'll check out some of those cups.