?

Log in

No account? Create an account
29 March 2014 @ 10:02 am
Hello everyone,
so I'm having the same problem on my last post! I have tried checking to make sure that the cervix is covered by the cup (it is), I have tried different folds (been sticking with 7 fold and punch down), I have run my finger around the outside of the cup and pushed the wall of my vagina to make sure there's suction (it makes a sucking sound, so I guess that's working), and I've even done kegels! I did not leak when my period started in the daytime, but it leaked a teeny bit during the night (2 separate drops, not bad).
Another post said that the user had a much too heavy flow and it was overfilling. Well, it barely went over the double lines at the very bottom last night. So light (wow). However, there was a lot of slobber after waking up in the middle of the night to pee (hehe) and then waking up too pee in the morning (gotta stay hydrated). Like, a lot of it on me, but none on the pad I was using.

Any ideas what I'm doing wrong? The only other thing is that the stem pokes out a little, but it hasn't irritated me at all.

I have the Diva Cup 1 and would hate to have to replace it (super broke college student, yay). Any ideas what is going on? I would love to master this thing during this cycle.
 
sammie_strange on April 2nd, 2014 06:42 pm (UTC)
Turns out I wasn't getting a good enough seal. When that thing suctions its way up in there, I have 0 problems with leaking. Used the 7 fold and had NO leaks! I'm so happy! :D