sunnybeebop (sunnybeebop) wrote in menstrual_cups,
sunnybeebop
sunnybeebop
menstrual_cups

Diva Cup leaking issues.

Sorry if I mess up this post some how... my first time on livejournal! Been stalking this community for a while, and I thought I had my cup figured out. But this cycle has been so frustrating !

I own two cups both the small size (Diva and Sckoon). I'm 23 no children. The Diva was the first cup I bought and my first cycle I used to the whole time- no leaks, no issues at ALL. perfect. Not even residual slobber, never had to wear a panty-liner. Honestly, after using the INSTEAD softcups I found diva cup very easy. Towards the end of that cycle, I had a bit of difficulty getting the Diva to open inside me easily- it always opened but it took a bit of coaxing. That's what made me buy the Sckoon, I figured since it was smaller it would open easier, which turned out to be true. It opens a bit easier than my Diva - I think the smaller size, and the rim of the Sckoon is slightly firmer than the Diva.

The second cycle I used both the Diva and Sckoon no issues- Diva only leaked on my first day when I think it got over full, (when I took it out it was about 3/4 full) and probably was almost completely full before the leak. Other than that no leaking with either- and I started using the 7-fold for inserting both cups. (I had been using the punch-down and C-fold previously). I would insert either cup just until the rim was in the entrance of my vagina, then unfold the folded 7 with my thumb or forefinger- then it would fill with air and I would push it into place while it was open. That worked flawlessly for the rest of that cycle and I thought I had it figured out.

This cycle not so much. I started off using the Diva, and using 7-fold like I had been. The first day I had lots of residual slobber and would feel a gurgle or bubbling. In the evening the Diva cup leaked red. Upon removal I saw the cup was only half full, if that. So I emptied and reinserted and an hour and a half later another leak, again the cup only 1/4 full. The gurlging made me think I was not getting a good seal with the Diva, so I switched to the Sckoon for the night and didn't use the 7-fold. I used C-fold and made sure to squish all the air out of the bottom before inserting. No leaks over night, used the sckoon all day no leaks. In the evening I decided to switch back to the Diva to see if I could get it to work. Before doing so I cut the stem completely off so It could sit lower, (I thought maybe a better seal if it can sit lower, maybe dangling cervix? - although my cervix is higher so I think its unlikely). I also used the c-fold squishing all the air out.... I got about 5 hrs of leak free doing this! BUT - before bed I had some bubbling, and clear brown slobber, then a few minutes later red blood. AGAIN when I removed the cup only 1/4 or 1/2 full. So I switched back to the Sckoon, the only leaks I've ever had with the Sckoon is some brown/clear discharge- resembling residual slobber.

When I insert either cup, I always make sure they are open fully. I insert pointing towards my tailbone, and I keep my cups sitting fairly low and they don't tend to move around or ride up. Normally I also try and give them a little tug or a turn to make sure they are snug. I think my problem with the 7-fold was too much air being let inside and it didn't make a good seal, But I just can't understand why the Diva isn't working now that I've switched back to the c-fold....especially since my last two cycles were so successful.

Any input would be amazing, sorry for the novel.
Tags: divacup, insertion, insertion - folding methods, leakage & spotting, sckooncup, seal & suction, sizes/size issues
Subscribe
  • Post a new comment

    Error

    Comments allowed for members only

    Anonymous comments are disabled in this journal

    default userpic

    Your reply will be screened

    Your IP address will be recorded 

  • 8 comments