?

Log in

No account? Create an account
09 January 2014 @ 06:52 pm
Of course, I join the community and sing the praises of the Diva cup, just to have major issues this cycle. This is my third cycle and I really feel like I've gotten the hang of it, and yet I'm having major leakage. My first cycle I had a couple of leaks, but for the most part was fine, which makes sense since I was just getting the hang of it. My second I had no issues. None whatsoever.

This time is an entirely different story. I'm finally really good at insertion and getting the seal. I can feel that it's opened completely and can even do the 360 degree turn that they recommend in the instructions. I also push a finger against the wall of the vagina to make sure it's had room to open fully and it has. Yet every single time, I get major leakage, and when I remove it, there's blood all along the outside and the cup isn't even half full. I can't figure out what's going on and it's driving me nuts.

I will take any suggestions I can get, and I've gone all throughout the forum and it doesn't seem that there's anything I haven't tried short of getting a new cup. I'm hesitant to think that that's the issue though since it worked so well the last time. I have the Diva cup 1, I'm 26 and have never had kids. I do have a heavy flow, but this is happening without overflow, so I can't quite figure it out. Normally my cervix is pretty high but during my period I can feel it, I'm not sure that that would be the issue either though since it's a pretty far reach (tmi, sorry)

Thanks for any help in advance.
 
(Deleted comment)
divacupaerb on January 10th, 2014 05:37 pm (UTC)
It doesn't seem to be any higher than last time. I've tried wearing it lower but it keeps moving upward to where it wants to be.
Kathlynekathlyne on January 10th, 2014 03:17 am (UTC)
I'm going to agree with the first comment, but explain it differently. Maybe the cup is opening to the side of your cervix rather than around it. I had some major issues until I figured out that was my problem. Instead of spinning the cup (which isn't necessary), I sweep/stir around the cup with my finger, if I can feel the end of my cervix then I reposition the cup and sweep again.

I hope this tidbit helps.
trejoytrejoy on January 10th, 2014 04:21 am (UTC)
I second this description heartily! It took a long time for me to figure out I was "missing" my cervix (like holding a glass next to a faucet instead of under it!)
divacupaerb on January 10th, 2014 05:12 pm (UTC)
I totally get what you're saying but I can't figure out how to ensure that it's opening up around the cervix. My cervix seems to be dead center, and I don't really have any option for putting the cup anywhere but where it is, it seems. It's a really tight fit as it is.

It's definitely full opening. I can tell that for sure. And what you're saying make PERFECT sense. I just can't figure out how I could do things any differently-- or what I'm doing differently this time vs. last time.

I just had some major leakage, removed the cup and it was completely covered in blood but there was hardly any inside at all! So clearly, SOMETHING is going wrong... I just can't see how it could be done differently.
Kathlynekathlyne on January 10th, 2014 06:10 pm (UTC)
Hmm. My cervix points to the left, so that's why I was having a problem. Maybe the cup is opening up in front of (more toward your pubis) or behind (more toward your back) your cervix.

Can you feel the end of your cervix? See if you can feel it without the cup in, and then with the cup in. If you can feel it with the cup in, then you need to readjust. Or try pressing the other wall of your vagina to let air in. I need to press the right side because I want the cup to open to the left.

Good luck.
..::bella vita::..por_que_no on January 10th, 2014 02:22 pm (UTC)
This happened to me with the Femmycycle (because it doesn't open up completely around the bottom, but it's supposed to open up top...but half the time mine would stay folded at the cervix too, until I figured out how to rotate it so it would open up)
(no subject) - rlycool on January 10th, 2014 04:21 am (UTC) (Expand)
divacupaerb on January 10th, 2014 05:37 pm (UTC)
Thank you!
divacupaerb on January 11th, 2014 04:14 am (UTC)
So I *think* I have figured out how to get it to seal properly, and it seems that that was the issue. The cup has definitely been settling around the cervix, but the seal hasn't been perfect. I got a good seal the last 2 times I used it tonight. I was going through old threads on the board and found one where someone had mentioned trying to push the side of the cup in once it was in, and fully opened, to let any trapped air out. Once I did that, both times, the seal was much stronger and I had a harder time pulling it low to get a good grip on it to turn it. I haven't had any leaks since, so that seems to have done it. I didn't have to do this my last cycle, but at least I have a new trick up my sleeve to try!

I am going to stick with the Diva Cup for now but I did add a large Lunette to my amazon wishlist to try at some point in the future. I think the larger, higher holes and larger capacity vs. the Diva 1 will be a big help.

Thanks for all of the replies!