?

Log in

No account? Create an account
08 January 2014 @ 08:38 pm
Hi everyone,

Firstly, thank you to all those who put up with my endless questions in trying to choose a new cup. I finally decided upon a soft Yuuki (large). It arrived and I used it last month and LOVED it. I was intimidated by it's size but had no problems, it opened right up without a hitch and while it presses on my bladder a little it's not unbearable like my Diva cup could be.

I would say it's my Goldilocks cup (or close to it) however on my first day last month, after only 2 1/2 hours, I went to the toilet (number 1) and felt this bubbling sensation and got leakage. I took my cup out which still had suction and felt sealed and emptied it. It wasn't full, it was only about half way. It didn't do it again so I put it down to teething trouble.

However this is my 2nd cycle with it and today it happened 3 times, all 3 times I still had suction and the cup wasn't full at all (not even up to the holes). It's not minor leaking like residual slobber, this is enough to colour the water (sorry, tmi). It doesn't seem to do it on my other days, only my first.

Anyone got any idea's what might be going on? I've considered the fact that perhaps I have a dangly cervix but it's more like the seal breaks when I pee (it only happens when I pee) and then reseals or something when I stand up? Thanks for any advice!
 
divacupaerb on January 9th, 2014 03:47 am (UTC)
A little leakage while peeing seems to be pretty normal from what I've read on here and also from my experience.
tobilei on January 9th, 2014 06:32 am (UTC)
Oh, okay, thanks so much :) This was a bit more than what I'd class as a little which is why I was concerned. Usually when I feel and hear that bubbly feeling it means my cup is full but wasn't the case any of these times. I appreciate the help!