lallibear (lallibear) wrote in menstrual_cups,
lallibear
lallibear
menstrual_cups

ouch :(

Hey all. I started using cups last month and ordered both a femmecup and a ladycup (for women who've given birth). The femmecup last month was great, no problems at all really except a couple of tiny teething issues. Used it yesterday fine but today couldn't seem to get it to pop..It inserted but was leaking, and it was def leaking and not residual.... so used the ladycup instead. First time I put it in this morning it was fine. Second time it kept popping before it was all the way in but I used kegels to get it up and it seemed ok. But I have had the most awful feeling of pressure and pain, hard to describe but sort of in a line running from hipbone to hipbone across my abdomen. I removed the cup which instantly relieved the pressure and lessened the pain but it still feels a little tender. Anybody have ideas why this may have been please?
Also, any hints for popping the femmecup? I could get it to pop last month and yesterday by running my finger around the rim but nothing doing the second time. In all honesty I was in a rush so didn't have much time to try and adjust it so it could have been a one off, but any hints in case it wasn't? and really, what was the pressure thing?! I'm feeling a little violated in my lady areas to tell the truth!!
Thanks :)
Subscribe
  • Post a new comment

    Error

    Comments allowed for members only

    Anonymous comments are disabled in this journal

    default userpic

    Your reply will be screened

    Your IP address will be recorded 

  • 4 comments