?

Log in

No account? Create an account
18 April 2012 @ 10:03 am
Hello I'm new to cup use and as I have browsed this forum I notice that my trouple is not unique.  But having said that I have tried all the advise that everyone has given and i'm still not having any luck.  Here are my details:
Dry run #1:  I used the c fold and inserted the diva cup just so the stem was still out and then did a full rotation and then pushed in until the stem wasn't causing a chaf.  I stood up and couldn't feel it so I removed the cup no problem
Dry run #2:  I knew that my period would be starting any time so I decided to wear my cup to my spin class.  I inserted the cup, stood up couldn't feel it so went to class.  When I got home, I went to remove it and could not feel it.  I extended my longest finger in all the way and could barley feel the tip.  The gyno has told me that I'm tiled back and to the side and that my uteris "hides" and to tell my family doctor that..  Anyway what I could tell from moving my finger around it was like I had a wall (pelvic bone) in my vagina and that the cup had fallen into it.  As a side note my cervix is very high as well.  I tried squatting, breathing, bearing down all while having my finger as deep as possible.  Every time I would bear down all I could feel was that it was hitting the wall aka my pelvic bone.  It took me 45 mins to get my finger able to get under the stem enough to lift it up over the bone and it would just keep falling back in because it was up so high.  I finally managed to use my two fingers like chop sticks and little by little of squatting and baring down i finally get it down enough to be able to use my fingers and thumb......  REALLY should it be this hard that I have to spend 45 mins of digging with my whole hand??? I do triathlons and I have a very heavy flow and was really looking forward to not having to cancel race days because of my period.
 
juliiie87juliiie87 on April 25th, 2012 01:53 pm (UTC)
As long as it doesn't hurt, and doesn't leak, it's probably sitting right.

I'm sorry I don't have a more detailed answer, maybe make another post if you are still having issues ? And good luck !