September 18th, 2015

Help! Problem after nearly 10 years of cup use?

Backstory: I've been using a diva cup since I was about 14 (the smaller size at first, upgraded to the larger size about 15 months ago due to a heavy period...I'm 23 now). For the majority of that time, I never used anything else. The past few years my periods have been getting heavier and heavier due to endometriosis, so in the past year I've purchased several of the larger capacity cups (the Meluna XL, Love Ur Body, and a Natural Mama) and just haven't found anything that works as consistently and easily as my Diva cup.

So on to my problem...I started my period mid afternoon today. I usually start over night and wake up with a mess, so it was unusual to start when I was at work. I just threw on an emergency panty liner and went about my day. I'm usually very light for the first 16 hours or so, I normally don't even notice it.

A few hours after I put in the panty liner I could tell I was bleeding heavier than I expected. I was also very sore (my vulva specifically, which is not normal for me). So I went into the restroom at work and tried to insert my reliable Diva cup. And for the first time in probably 8 years, I couldn't get it in! It felt like there was no lubrication at all and I just couldn't seem to get the cup inserted.

When I got home (probably 4 hours after I tried to insert the Diva cup the first time) I tried to insert the Natural Mama since it's a little softer. Still no go. It actually hurt so badly I could hardly get it out, so I'm just using a pad for now.

Is my best bet to just use some lubricant on the cup to insert it in the morning? Did I try to insert it too early in the cycle? Has anyone else had this problem? I'm wondering if this is something I need to go see my gynecologist about or if it can be a normal thing.