December 13th, 2005

Cramp-like Discomfort

My period started yesterday and this is my third cycle with the Diva Cup. Overall, I've been able to figure out some of the issues I had earlier difficulties with, not limited to insertion, removal, cleaning, and other stuff. I've had no problems with leaking, it's been terrific as far as performance.

In terms of insetion, I use the simple "C" fold technique (the one in the original instructions), lube, and insert. It sort of gets sucked in after the initial insertion and then just sits comfortably. I've never been able to pop it open manually, but when I stand up and move, I can feel it open up by itself.

The thing I've had concern with is that I have a weird, constant, mild discomfort. I can only discribe it as mild, but constant cramping. I'm wondering if this is a fit or positioning issue? The first cycle, I had a sense that I could feel the cup itself. By the second cycle, that sensation went away, but I still had the discomfort.

Not sure what else I can mention and hope this isn't too vague. I also looked through the memories and recent posts, but I didn't see anything exactly this. I did see comments that some women may have issues with the cups increasing, or causing cramping even though the cups are better known for helping to ease cramping.

Thank you.
  • nimue74

Tilted uterus and the Diva Cup

This is my first post here. I have used the Diva Cup for one cycle and my second is quickly approaching. So I thought I should ask my question sooner rather than later.

I have a tilted uterus which puts my cervix VERY near my vaginal opening. The problem I am having is that when the Diva 'pops' open it usually hits the side of my cervix as opposed to covering it. I have tried the c-fold and the punch down method and both seem to cause the problem. The only way I have been able to get this to work so far is to c-fold the cup and put it in a tiny way, then let it open and push it the rest of the way in (no suction created). Once I get it in then I squeeze it and the air escapes so when I let go it has a little suction. It still tends to slip throughout the day, but not too bad. I fear, however, that in doing it this way I may be forcing air where it isn't intended to go and may cause myself some problems.

Anyone else have this problem and found a solution, or anyone have some ideas for me on how to fix this?

Thanks.