Sarah (1girl) wrote in menstrual_cups,
Sarah
1girl
menstrual_cups

Fingernails and insertion & brownish discharge in my cup

Hi everyone.  I just got my first cup in the mail today and was really eager to try a test run, as my period will be starting soon. I have two questions.

1.  I was bracing myself for the worst, but I managed to get it in using the C-fold after about 3 tries.  It was rubbing sort of funny, so I took it out and looked up some other folds.  I tried the origami fold, which worked great, much easier to get in.  But here's my problem-I kept scratching myself with my nails while inserting the cup.  Has anyone else had this problem?  My nails aren't super long, but they definitely protrude over the tops of my fingers.  Is this something that gets better over time as I get better at maneuvering my cup around or am I just going to have to clip my nails once a month?

2. I wore my cup around the house for a couple of hours just to see how it felt, and when I took it out there was some brown discharge pooled in the bottom.  It kind of freaked me out a little bit.  I normally have some discharge during your average day, but it's always the garden variety clearish-white kind.  My period is still several days off, and I know I don't have an STD (I was tested a couple of months ago).  I guess maybe my vagina just wasn't happy with me poking and prodding it for a while or it might be period related.  I suppose I'm really just looking for reassurance here.  :)

Thanks everyone!
Tags: first time use, insertion, removal
Subscribe
  • Post a new comment

    Error

    Comments allowed for members only

    Anonymous comments are disabled in this journal

    default userpic

    Your reply will be screened

    Your IP address will be recorded 

  • 6 comments