æ (hashire) wrote in menstrual_cups,
æ
hashire
menstrual_cups

So, I got my first DivaCup last month, and got the chance to try it out today (skipped last month due to stress). I'm having some problems.

I assume I'm putting it in right; last time I emptied and put it back in, I did the full rotation and stuck a finger it to make sure it was in properly. However, I'm not sure if there's leakage or if there is just some blood leftover from when I have it out to clean that's making its way out. I have been laying down for the past few hours, but I don't think that should make a difference. Since this is a my first time around I've had pads on for backup, but I don't really want to have to deal with this every month.

Also, with that, when I'm putting it in I'm worried about forcing air in higher. I try to not let much get in, but it's hard to get it in without having some air in to let it open. The instructions are vague beyond just putting it in, and I don't want to do some sort of damage. I just want to make sure I'm doing it right. There's also a little pain in my uterus after doing it, but that might be attributed to the fact that I push it up a little harshly when getting it in fully.

And one last thing that's semi-related: when I took it out awhile ago, I decided to look at the contents. The first two times taking it out, it just kinda flicked into the toilet because I was still working on doing things right. Anyway, on top of the blood there was some clear fluid that was separate from the blood. I'm just curious as to what it is.
Tags: divacup
Subscribe
  • Post a new comment

    Error

    Comments allowed for members only

    Anonymous comments are disabled in this journal

    default userpic

    Your reply will be screened

    Your IP address will be recorded 

  • 10 comments