saiyukigin (saiyukigin) wrote in menstrual_cups,
saiyukigin
saiyukigin
menstrual_cups

Lunette came in the mail today!! :D

So, I got my Lunette in the mail today! Yay! It shipped super fast. On the website it said 7 to 8 business days, but it was just 4. 

I read the instructions that came with it and tried a dry run. I washed the cup first with some mild soap instead of boiling it like they recommended. I didn't really have any problems or pain inserting the cup (I used the C-fold). I did have some problems with popping it open. It wanted to stay in the c-fold shape. I tried swirling the cup, but that didn't work for me. So I removed the cup and I don't know if I got the angle wrong or what but that hurt! I decided to try the whole thing again (I'm the kind of person that will do something until I get it right. I can be pretty hard headed lol) So on the third time I think I got the cup to seal, although I didn't feel a pop like I've read that people have felt. But when I ran my finger around the cup this time I didn't feel any dents or folds. So that should mean that it sealed, right??

I also notice while the cup was inside me that I felt like I had to pee big time! I've also read here that sometimes some women experienced this and that the sensation went away after a few periods using the cup. To those women: Did it feel like that the whole time you where using the cup though out your period?  I think that might be really hard for me to deal with if so.

Sorry if my post is all over the place. I never very good at organizing my thoughts, though, I did try!

Thank you all in advance!!

Tags: dry run, lunette, popping open, seal & suction
Subscribe
  • Post a new comment

    Error

    Comments allowed for members only

    Anonymous comments are disabled in this journal

    default userpic

    Your reply will be screened

    Your IP address will be recorded 

  • 8 comments